Payments Processing Degraded Performance Impacting myKaarma

Incident Report for myKaarma

Resolved

The payment processing issue affecting mK payments processing dealers has been fully resolved, and any transactions impacted during the incident will be later reconciled. Thank you for your patience while we worked to restore everything.
Posted Dec 01, 2025 - 11:16 PST

Identified

The payment processing issue affecting mK payments processing dealers has been fully resolved, and any transactions impacted during the incident will be later reconciled. Thank you for your patience while we worked to restore everything.
Posted Dec 01, 2025 - 10:41 PST

Investigating

Some dealers are experiencing trouble processing payments and may notice missing payment logs due to an internal issue. Please only attempt transactions once to avoid duplicate transactions. You can continue to take payments using the backup link at mkpay.us. Thank you for your patience while we investigate the impact and cause, and we will share another update within an hour.
Posted Dec 01, 2025 - 10:25 PST
This incident affected: myKaarma Payments (Online Payments (Consumer-facing)).