myKaarma Application Performance Issues Impacting Some Dealers

Incident Report for myKaarma

Resolved

The issue causing slowness and freezing in the myKaarma web and desktop applications for some dealers has been resolved, and systems are operating normally. We implemented fixes to address the underlying issue and are continuing to monitor for stability. Thank you for your patience, and we’re sorry for the disruption.
Posted Apr 02, 2026 - 13:26 PDT

Identified

We have implemented a couple of fixes to address the slowness and freezing issues affecting some dealers in the myKaarma web and desktop applications and are currently monitoring to confirm resolution. We’ll provide another update within the next hour.
Posted Apr 02, 2026 - 12:22 PDT

Investigating

We are investigating an issue where some dealers are experiencing slowness and occasional freezing in the myKaarma web and desktop applications. Our team is actively working to identify the issue. We’ll provide another update within the next hour.
Posted Apr 02, 2026 - 11:11 PDT
This incident affected: myKaarma Dealer-Facing Apps (myKaarma Desktop App, myKaarma Mobile Apps).