Insights Page Loading Issue Impacting myKaarma

Incident Report for myKaarma

Resolved

This issue has been resolved, and the Insights page is now loading as expected for users with multistore access. Our team identified the cause and deployed a fix, and users may need to refresh the page or switch to another tab and back to Insights for it to load normally again. We will continue monitoring for stability and appreciate your patience while this was addressed.
Posted Mar 03, 2026 - 06:12 PST

Investigating

We are investigating an issue where users with multistore access may find the Insights page stuck on the loading screen. We’re actively working to restore normal loading behavior and will provide the next update as soon as it’s available.
Posted Mar 03, 2026 - 05:58 PST
This incident affected: myKaarma Insights (Insights Dealer-facing page).