Third-Party API Degradation Impacting Vin Decoder

Incident Report for myKaarma

Resolved

All systems are operational.
Posted Jun 10, 2025 - 10:24 PDT

Identified

Dear myKaarma User, We are currently experiencing an issue with VIN decoding due to a third-party service disruption. This may cause errors when you attempt to add vehicles using their VIN and may sometimes display incorrect vehicle availability. To help fix this, our team is closely watching the situation and working directly with the service provider. In the meantime, we have adjusted our system to try one main source first for decoding VINs, and only if that doesn’t work, we will try a backup source. This should reduce errors as much as possible. We will keep you updated as we learn more. Thank you for your patience and understanding.
Posted Jun 10, 2025 - 08:13 PDT

Investigating

Dear myKaarma User, We are currently experiencing an issue with VIN decoding due to a third-party service disruption. Users may encounter errors when adding vehicles through VIN. This may also cause discrepancies in vehicle availability. Our engineering team is monitoring the situation closely and is in contact with the third-party provider to expedite resolution. We will provide updates as soon as more information becomes available. We appreciate your patience and understanding.
Posted Jun 10, 2025 - 04:49 PDT
This incident affected: myKaarma Scheduling (Web Scheduler (Consumer-facing)).