The NMI device payment issue has been fully resolved. Device payments are operating normally, and refunds for duplicate transactions are now working as expected. If you encounter a similar payment issue in the future, please check the Payment Report tab to confirm whether the original payment was successful before attempting another transaction. Thank you for your patience, and we’re sorry for the disruption.
Posted Aug 07, 2026 - 11:13 PDT
Investigating
We are investigating reports of NMI payments showing an error or decline in myKaarma even though the transaction may have been processed successfully and may appear as pending in the customer’s banking app. We recommend avoiding additional payment attempts for the same transaction while we investigate to help prevent potential duplicate charges. We’ll provide another update as more information becomes available.
Posted Aug 07, 2026 - 10:12 PDT
This incident affected: myKaarma Payments (Desktop Payments (Dealer-facing)).