Inspect Performance Issues Impacting myKaarma

Incident Report for myKaarma

Resolved

The issue affecting the Inspect tab and RO syncing in myKaarma has been resolved, and services are operating normally again. Dealers should no longer experience slow loading in the Inspect tab or issues with repair orders pulling into myKaarma. We apologize for the disruption and appreciate your patience
Posted May 21, 2026 - 05:18 PDT

Investigating

We are investigating an issue affecting the Inspect tab and RO syncing in myKaarma. Dealers may experience the Inspect tab loading slowly or not loading, and some repair orders may not be pulling into myKaarma. Our team is actively working to restore normal performance. We’ll provide another update as soon as more information is available.
Posted May 21, 2026 - 04:35 PDT
This incident affected: myKaarma Inspections (Service Cart).