Insights Loading Issues Impacting myKaarma

Incident Report for myKaarma

Resolved

The issue impacting data loading under the Insights tab for some dealers has now been fully resolved. All systems are operating normally. We apologize for the disruption and appreciate your patience while our team investigated the issue. Please reach out to Support if you continue to experience any problems.
Posted Feb 02, 2026 - 06:20 PST

Investigating

We are investigating an issue where data under the Insights tab is not loading for all dealers. The cause is still under investigation. We’re sorry for the disruption and will provide the next update as soon as possible.
Posted Feb 02, 2026 - 05:32 PST
This incident affected: myKaarma Insights (Insights Dealer-facing page).