Service Cart Slowness Impacting myKaarma

Incident Report for myKaarma

Update

We have identified the cause of the slowness and loading issues in Service Cart and are currently working on a fix to restore normal performance. Dealers may continue to see slow or delayed loading while this work is underway. We’ll provide another update within the hour.
Posted Feb 18, 2026 - 12:46 PST

Identified

We are investigating reports of slowness and loading issues in Service Cart. Our team is actively working to identify the source of the problem. We’ll provide another update within the hour.
Posted Feb 18, 2026 - 11:49 PST
This incident affects: myKaarma Inspections (Service Cart).