Intermittent Issues with myKaarma Application

Incident Report for myKaarma

Resolved

All systems are operational.
Posted Jun 30, 2025 - 13:44 PDT

Identified

Dear MyKaarma User, we are still investigating an issue impacting application performance, specifically related to Internal Messages and the Customer tab. Our engineering team is actively working to identify the root cause and implement a solution. We understand the impact this may have on your daily operations and truly appreciate your continued patience as we work toward resolving the issue. We will share additional updates as soon as more information becomes available.
Posted Jun 30, 2025 - 08:23 PDT

Investigating

Dear MyKaarma User, We are currently aware of an issue affecting app performance, including slowness and reduced responsiveness. Our engineering team is actively working to resolve the problem as quickly as possible. We appreciate your patience and understanding while we work to restore optimal service.
Posted Jun 30, 2025 - 07:36 PDT
This incident affected: myKaarma Dealer-Facing Apps (myKaarma Desktop App).