Our engineering team is diligently working to restore full service and is closely monitoring the application's performance. If you are still encountering issues with payment processing, we recommend using mkpay.us as an alternative. We appreciate your patience and understanding as we continue to resolve the situation.
Posted Mar 11, 2025 - 15:51 PDT
Update
myKaarma's engineering team is continuing to make progress on restoring our services; however, we are not yet fully back online and are continuing to monitor the health of our application. If you experience any issues processing payments, please use mkpay.us as an alternative. We will continue to provide updates as soon as possible. Thank you for your patience and understanding.
Posted Mar 11, 2025 - 15:22 PDT
Identified
myKaarma's engineering team is continuing to work on restoring our services. DMS integration, including RO and appointment pulling, and application speeds may continue to be reduced at this time, but we will continue to update you here as we know more. If you encounter any further issues processing payments, please use mkpay.us as an alternative. Thank you for your patience and understanding.
Posted Mar 11, 2025 - 14:22 PDT
Investigating
We are currently experiencing intermittent issues with the myKaarma application. Our engineering team is actively investigating the situation and working on a resolution. We will provide an update as soon as possible. Thank you for your patience and understanding.
Posted Mar 11, 2025 - 13:20 PDT
This incident affected: myKaarma Dealer-Facing Apps (myKaarma Mobile Apps).