Inspect Tab Loading Issues Impacting myKaarma

Incident Report for myKaarma

Resolved

This issue has been resolved and the Inspect tab is now loading normally. Our team will continue to monitor and investigate the root cause. Thank you for your patience, and we’re sorry for the disruption.
Posted Mar 26, 2026 - 05:43 PDT

Investigating

Dealers are experiencing issues with the Inspect tab not loading and may see an “error when fetching inspections” message. Our engineers are actively investigating and working to resolve this issue. We will provide an update as soon as possible.
Posted Mar 26, 2026 - 05:19 PDT
This incident affected: myKaarma Inspections (Service Cart).