Insights Tab Loading Issue Impacting myKaarma

Incident Report for myKaarma

Resolved

This issue has been resolved, and the Insights tab is now operating normally. We identified and resolved the issue that was causing the myKaarma dashboard loading screen to remain stuck when accessing Insights, and we will continue monitoring to ensure stability. Thank you for your patience, and we're sorry for the disruption
Posted Jul 14, 2026 - 13:01 PDT

Investigating

We are investigating an issue affecting the Insights tab. Some customers may see the myKaarma dashboard loading screen indefinitely when attempting to access Insights. Our team is actively investigating the issue and working to restore normal functionality. We’ll provide another update within the next hour.
Posted Jul 14, 2026 - 12:58 PDT
This incident affected: myKaarma Insights (Insights Dealer-facing page).